Payment delays
Incident Report for Westpac New Zealand
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 15, 2019 - 14:22 NZST
Investigating
We are currently experiencing delays with some international payments. Our tech teams are aware of this issue and are working to resolve it.
Posted 3 months ago. Jul 15, 2019 - 13:09 NZST
This incident affected: Payment Services.