Westpac Pay - Problems Adding Cards to Westpac Pay
Incident Report for Westpac New Zealand
Resolved
The issue has now been resolved and the Westpac Pay service is now fully available

We apologise for any inconvenience caused
Posted 11 months ago. Jul 25, 2018 - 15:47 NZST
Investigating
We are currently experiencing problems with adding credit or debit cards to Westpac Pay, cards already added to the service will be unaffected

We apologise for any inconvenience caused.
Posted 11 months ago. Jul 25, 2018 - 14:46 NZST
This incident affected: Online Channels (Westpac Pay (Android Mobile Payments)).