Convention Centre Fire
Incident Report for Westpac New Zealand
Resolved
The Mid City branch has reopened.
Posted Oct 25, 2019 - 09:02 NZDT
Update
Thursday: The Mid City branch remains closed today.
Posted Oct 24, 2019 - 09:31 NZDT
Identified
Due to the smoke from the Convention Centre fire, the Mid City branch at 229 Queen St, Auckland is closed today. The nearest branch open is 79 Queen Street. We apologise for any inconvenience.
Posted Oct 23, 2019 - 09:34 NZDT
This incident affected: Westpac Branches.