Contact Centre delays
Incident Report for
Westpac New Zealand
Resolved
This incident has been resolved.
Posted
Aug
01
,
2024
-
13:12
NZST
Investigating
We’re currently experiencing technical difficulties with our Contact Centre and wait times are longer than normal.
We’re working to urgently fix this. We apologise for the inconvenience.
Posted
Aug
01
,
2024
-
09:09
NZST
This incident affected: Contact Centre.
×
Subscribe to Incident
Subscribe to updates for
Contact Centre delays
via . You'll receive .