Westpac One Business unavailable

Incident Report for Westpac New Zealand

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 11:45 NZDT

Identified

Westpac One Business is currently unavailable.

Tech teams are engaged and are working to fix this as soon as possible.

We apologise for the inconvenience.
Posted Mar 20, 2025 - 09:25 NZDT