High value payments delay
Incident Report for Westpac New Zealand
Resolved
This incident has been resolved.
Posted 10 days ago. Oct 07, 2019 - 16:04 NZDT
Investigating
Some customers are experiencing a delay in outward payments instructions. We are investigating the issue and apologise for any inconvenience caused.
Posted 10 days ago. Oct 07, 2019 - 12:43 NZDT
This incident affected: Payment Services.