Kilbirnie Branch
Incident Report for Westpac New Zealand
Resolved
This incident has been resolved.
Posted 2 months ago. Mar 22, 2019 - 14:17 NZDT
Identified
Our Kilbirnie branch will be closed on Friday 22 March from 1pm-2pm so that staff can attend a ceremony at the Kilbirnie Mosque. Thank you for your understanding.
Posted 2 months ago. Mar 19, 2019 - 16:01 NZDT
This incident affected: Westpac Branches.