Duplicate payments
Incident Report for Westpac New Zealand
Resolved
This incident has been resolved
Posted about 1 month ago. Sep 05, 2019 - 20:38 NZST
Investigating
Some customers have reported duplicate Direct Debit payments. This issue is being investigated and we apologise for the inconvenience. If this issue is causing hardship, please contact our Contact Centre or email us at customer_support@westpac.co.nz
Posted about 1 month ago. Sep 05, 2019 - 09:40 NZST
This incident affected: Payment Services.